Broken Throttle Linkage | The Z Club of Great Britain
  1. The Z Club relies on the support of it's paid members - join the club or renew your membership here.

Broken Throttle Linkage

Discussion in 'Engine' started by Peato40, Dec 11, 2019.

  1. Peato40

    Peato40
    Z Club Member

    Hello All,

    A short Sunday run out was cut even shorter when I lost throttle. The attached photo shows the culprit and therefore I wondered if this might be a common problem and has anybody found a reliable method of repair?

    If anybody has a spare I would be very interested.

    Any advice is gratefully received.
     

    Attached Files:

  2. Mr Ex Jnr

    Mr Ex Jnr
    Z Club Member

    I have a few what size is it
     
  3. Mr Ex Jnr

    Mr Ex Jnr
    Z Club Member

    Linkages
     

    Attached Files:

  4. Peato40

    Peato40
    Z Club Member

    Thanks but do you mean size of ball or length of the rod?
     
  5. Mr Ex Jnr

    Mr Ex Jnr
    Z Club Member

    Length of the rod
     
  6. Peato40

    Peato40
    Z Club Member

    Its the one that goes through the bulkhead and is about 130mm - 140mm I'll need to get it off for a more accurate measurement
     
    Mr Ex Jnr likes this.
  7. Mr Ex Jnr

    Mr Ex Jnr
    Z Club Member

    Yeah take it off and measure it will check then with what I have
     
  8. Peato40

    Peato40
    Z Club Member

    Assembled length is 130mm.

    2.jpg 1.jpg
     
    Mr Ex Jnr likes this.
  9. Rob Gaskin

    Rob Gaskin Treasurer Staff Member Moderator

    Give Jen her ruler back!

    I'll have a look but have you tried the internet for rods in general?
     
  10. Peato40

    Peato40
    Z Club Member

    Thanks Rob, I have thought about converting to clevis if all else fails. I can get a replacement rod from the US but seems like a lot of trouble for something as small as this.

    Possession is apparently 9/10th of the law here in the UK ..... So the ruler is now all mine EXTRA:)
     
  11. Mr Ex Jnr

    Mr Ex Jnr
    Z Club Member

    Will have a look on box of bits tonight
     
  12. Peato40

    Peato40
    Z Club Member

    Much appreciated
     
    Mr Ex Jnr likes this.
  13. stuart barrie

    stuart barrie
    Z Club Member

    Just a quick thought why did it break?
    If the linkage is not set properly you may end up breaking another one.
    Check if the pedal contacts the stop on the floor before over stressing the linkage of the carbs are fully open before the pedal contacts the stop.
     
  14. Peato40

    Peato40
    Z Club Member

    Hi Stuart, yes it's a very good point but in this case I think the reason for failure is simply old age or poor prior repair. There looks to be some evidence of glue at the failure point, so I'm not convinced this is the first time this has broken.
    @Rob Gaskin has given me a replacement rod that I can work with, so should have this fixed in a couple of days.

    Thanks all for comments and feedback
     

Share This Page