Gearbox issue | The Z Club of Great Britain

Gearbox issue

Discussion in 'S30 (240Z,260Z,280Z) Drivetrain' started by johnymd, Nov 22, 2016.

  1. johnymd

    johnymd Active Forum User

    My gearbox has suddenly got a problem!!!

    It has been fine and was OK when I put the car in the garage yesterday. Today when I tried to reverse out the car would not move and the engine stalled. I tried again and found the gearbox appeared to be locked. I put it in neutral and started to release the clutch and it started going forward. I tried to select 1st, 2nd, 3rd and 4th but I couldn't get the gear lever to move to any of those gears. From neutral it wouldn't even go across to the 1/2 position. Feels fine going between 5/R.

    Does this sound repairable?
  2. Rob Gaskin

    Rob Gaskin Membership Secretary

    Well that sounds like a major problem but I would have hope because it was ok when you left it last night.

    I guessing wildly but perhaps a selector fork has become loose on the shaft (roll-pin broken?) and you are still in that gear?

    So when you selected reverse today you are in two gears???
  3. johnymd

    johnymd Active Forum User

    Pretty much what I'm thinking Rob. It is a 5 speed zed box by the way.
  4. jonbills

    Z Club Member

    I agree - most likely easily fixed once you get in there.
  5. johnymd

    johnymd Active Forum User

    Thanks for the words of encouragement. I'll wip it out and pull apart tomorrow.
  6. uk66fastback

    Z Club Member

    Interesting! Can't be much surely having been okay last night ... ?

    Please take pics of what you find if you can ...
  7. stuart barrie

    stuart barrie
    Z Club Member

    I would think when you get into the box and check selectors ther will be nothing broken as I had this happen with another can not a zed when someone else moved the car and it got left in reverse gear with the lever in neutral. The lever that moves in an H pattern basicly sliped between the gates.
    Once the box was striped it only required the offending gate to be lined up with the other two using wide flat screwdriver at the narow pinch point and twist.
  8. MikeB

    MikeB Forum User

    Sounds like the 1/2 selector fork is loose and stuck in gear, hence why you can't move it into that plane, the detente plunger is across and hence why you can't get 3/4, but it still moves in 5/R.

    As has been said a hopefully simple fix once you get inside ;)
  9. johnymd

    johnymd Active Forum User

    I've never been inside a gearbox so I guess now is a good time to start. After all, its broken so nothing to lose and everything to gain experience wise.
  10. Rob Gaskin

    Rob Gaskin Membership Secretary

    John, they come apart easily and the 'guts' stays together when you remove the casing. First time is always the worrying time, after that it's a piece of cake. Dismantling the gears themselves is not to be taken lightly though.

    Open it up first and see if there is anything obvious.

    Before you do that, have you definitely tried 'coaxing' it into life?

    Attached pic shows a broken selector fork on my S14 box. You were at Mallory Park the day that happened and I could still drive it.

    Attached Files:

  11. uk66fastback

    Z Club Member

    First rule (for me anyway):

    Taking things apart ... take pics as you go ... invaluable I find.

    the times in the past I've done half a job, gone back to it and I can't remember exactly how it goes back together - not just cars - other things ...
  12. jonbills

    Z Club Member

    Step 1: snap ring pliers!
  13. johnymd

    johnymd Active Forum User

    Getting it apart is not proving that easy!!!

    Took the box out this morning and started to strip the casings off. Rang a few people and read some stuff on the internet to equip myself with a bit of knowledge.

    1. Removed the nose housing bolts in the bellhousing and prised this cover off with a little sharp pry bar through the clutch actuator hole and it pretty much fell off.
    2. Removed both the snap ring and the circlip easy enough with a cheap pair of circlip pliers and a couple of shall screw drivers.
    3. Removed the center casing bolts and reverse switch. Then pulled the bellhousing section off.
    4. Everything looked fine inside at that end so tried to remove the tail section.
    5. Remove the speedo drive, gearlever tension bolt and pin next to it.

    Case still wont come apart!! It separates about an inch then stops. Is there anything else I should be doing? as I'm about to give up.
  14. johnymd

    johnymd Active Forum User

    Is it because its stuck in gear? Maybe the selector arm is locked onto something inside?
  15. jonbills

    Z Club Member

    Yes, maybe being held by the check balls (think that's what they're called).
    If you carefully remove those other bolts on the centre plate one at a time you should be able to remove the selector check balls and springs.

    Actually, that's all rubbish. ignore it.
    Last edited by a moderator: Nov 23, 2016
  16. Rob Gaskin

    Rob Gaskin Membership Secretary

    John, I wonder if the ratchet is stopping you. There is a mechanism to stop engagement of reverse from 5th. This is on late boxes. The pic is an S14 one but it may help you understand what I'm thinking. You may have to just twist the rod to move the selector bit away from the ratchet if you know what I mean? It can be in the way when reassembling too (from memory).

    Attached Files:

  17. johnymd

    johnymd Active Forum User

    All disassembled, thanks for all the advice. I just needed to rotate the selector so it disengaged with the 3 forks in the box. I still cant find anything wrong with the box itself and it all looks like brand new. I'll keep looking.
  18. MikeB

    MikeB Forum User


    You should be able to move the selector rods by hand, if everything is OK.

    Check that the selector forks are firmly attached to the rods.

    I once had a box from a Mini that seemed to work fine when you spun the input shaft, but it wasn't until you simulated putting on a load by holding the output and turning the input that I discovered a fork that was loose. They are very fickle things, gearboxes.
  19. Huw

    Z Club Member

    Hi John.

    Had a similar problem on with a Fiat. One of the spring loaded ball bearings that hold the selector rods in place had jammed in its socket stopping the selector rod from moving. Not saying this is your issue, but something easy to check.

  20. Lurch

    Lurch New Forum User

    You need to put your finger in the hole in the shifter striker rod, so you can move it to make the finger move out of the fork ends.
    Then you can remove the housing.

    What's happened is somehow you've selected 2 gears in the gearbox - they why it's locked up.
    It can happen & I suggest you look for wear on the finger & in the slots of selector rails.
    Also make sure the oil can escape the front bearing housing where the shifter rails move into, as if it has the wrong cover without the oil drain, you'll be 'hydraulicing' the rails & forcing two gears to be selected.

Share This Page