Ignition module (E12-80)

Broughton

Club Member
I've searched this site (and other sites too) but cannot find how to test the subject ignition module. Can anyone help?
 

Broughton

Club Member
What car is this for do you mean the black box on the side of the distributor?what are the symptoms?
Car is special using 280ZX engine and yes, the black box. Symptoms ................. engine fires-up on the key for mere second or two then dies.
 

jonbills

Membership Secretary
Staff member
Site Administrator
Car is special using 280ZX engine and yes, the black box. Symptoms ................. engine fires-up on the key for mere second or two then dies.
second or two, or dies immediately you let it off cranking?
I don't know how yours is wired, but on the original cars, there's a CRANK +ve feed to the coil and a RUN +ve feed to the coil.
If the RUN wire is disconnected, it'll start on the cranking feed, but die immediately you stop cranking.

alternatively, might be worth checking the fuel pressure in the rail - I can imagine ways for it to build enough pressure before cranking, but then be insufficient straight after.
 

Broughton

Club Member
Hi Huw.
The copied pages are most useful (please name the book/ manual so I might obtain a copy). Not only test for ignition unit but for pick-up coil as well. Great!
So, with the ignition unit plugged into the dizzy and 400ohms at the pick-up coil all should be well. I'll test in next couple of days or so and let you know.

Very many thanks.
 

Broughton

Club Member
second or two, or dies immediately you let it off cranking?
I don't know how yours is wired, but on the original cars, there's a CRANK +ve feed to the coil and a RUN +ve feed to the coil.
If the RUN wire is disconnected, it'll start on the cranking feed, but die immediately you stop cranking.

alternatively, might be worth checking the fuel pressure in the rail - I can imagine ways for it to build enough pressure before cranking, but then be insufficient straight after.
Hi Jon.
Thanks for your input. Good stuff!
"Special" in this case means, amongst other things, the fuel injection is replaced by a couple of SU's and the wiring is not Datsun.
Fuel is provided by elect. pump which, for purpose of problem solving the present issue, I've jury rigged to run continuously so there ought not be an issue with fuel supply.
Most irritating because the engine cut out whilst going through MOT and only one more check to complete (brakes) other wise clean bill of health. Examiner had to issue MOT "FAIL".

Cheers
 

Huw

Club Member
Hi Huw.
The copied pages are most useful (please name the book/ manual so I might obtain a copy). Not only test for ignition unit but for pick-up coil as well. Great!
So, with the ignition unit plugged into the dizzy and 400ohms at the pick-up coil all should be well. I'll test in next couple of days or so and let you know.

Very many thanks.
Glad it was helpful. It’s a factory service manual, they tend to crop up on eBay for the different years . Mines a 79.
 

SteveG

Club Member
Probably not useful comment, but I had trouble with an ICM. I accidentally touched the wire to the ICM and the engine cut out. This was quite repeatable. Anyway, I cleaned up the connections and have had no issue since.
 
Top