No username? Register here.
Go Back   ZClub.net > General > Rebuilds and restorations
MJP AUTO

Reply
 
Thread Tools Display Modes
  #76  
Old 02-04-2017, 08:57 AM
imustaveit imustaveit is offline
Z Club member
Third gear
 
Join Date: Dec 2011
Location: Whitehaven Cumbria
Posts: 277
Member 869
Thanks for the comments all, it's one thing getting good feedback from fellow petrolheads, but it's so much better getting it from people who know the marque. The car has progressed a lot further but I'm slow at posting progress reports.

Paul
Reply With Quote
  #77  
Old 02-04-2017, 10:10 AM
Rob Gaskin's Avatar
Rob Gaskin Rob Gaskin is offline
Membership Secretary
Sixth gear
 
Join Date: Dec 2002
Location: Hinckley
Posts: 9,864
Member 214
I've posted on here before but I'll do it again - I'm absolutely amazed by your dedication and attention to detail. You are doing a fantastic job BUT are you sure you'll want to drive it when it's finished.

I think this one must be a show piece in a museum (or Nissan Dealer) and you need another that's not so perfect for driving and risking.
__________________
240Z '71 Built and Modified by DJR
Reply With Quote
  #78  
Old 02-04-2017, 02:43 PM
Albrecht Albrecht is offline
Website member
Fifth gear
 
Join Date: May 2003
Location: Up a ladder...
Posts: 2,890
Lovely job. Big thumbs up from me.
Reply With Quote
  #79  
Old 02-04-2017, 09:06 PM
imustaveit imustaveit is offline
Z Club member
Third gear
 
Join Date: Dec 2011
Location: Whitehaven Cumbria
Posts: 277
Member 869
Thanks guys, your right Rob I will be nervous driving it, I've never restored a car before and wanted to keep it as close to original as it was when I got it. I've loved doing the car and spent a lot of time with my sons doing it. I have had other sports cars (my current daily driver is a Porsche 996) but never felt the affection that I have with the Z, I've never been afraid of bending or selling the others but would hate to do either with the Z, I'll never sell it and I've already started collecting panels should the unthinkable happen....
Paul
Reply With Quote
  #80  
Old 08-04-2017, 05:44 PM
imustaveit imustaveit is offline
Z Club member
Third gear
 
Join Date: Dec 2011
Location: Whitehaven Cumbria
Posts: 277
Member 869
Hi all, making a bit of time for an update concerning fitting the engine. Finally got it in but ended up putting it in twice The first time we fitted it (my sons and I) I couldn't get the gearbox to engage, after much deliberation I convinced myself that the problem had to be clutch related and therefore the engine/gearbox would need to come back out so that I could split them and check the clutch fitment. Having done that and finding nothing wrong I refitted the engine/gearbox only to find the problem still there - very frustrating. A bit of further investigation on the net through forums such as this one pointed me to the new clutch master cylinder that I'd fitted. It turns out that although described as fitting the 240z (the cylinder size is correct) the piston rod that comes fitted is actually shorter than the original and so the clutch isn't engaged fully when operated.So after exchanging the original longer Piston Rod into the new master cylinder it operated perfectly, I was both relieved that it worked but annoyed that the part supplied was wrong in the first place causing a lot of rework. Another mistake I made was forgetting that the engine mounts are left and right handed, so although bolting in with a lot of difficulty I found I couldn't fit the air filter box because the gap between the engine and inner wing was to small (the engine was leaning to the passenger side rather than drivers side (as shown in one of the pics). Before refitting the engine for the second time I took the opportunity to send the gearbox away locally to have it aqa-blasted, as I was never happy with my attempts to clean the gearbox. I made the right decision as when it came back it looked new, really happy with the finish. With everything finally correctly fitted including my rebuilt carbs from ZTherapy we fired the engine up. It was perfect and I couldn't have hoped for a better result. So after some frustration (most of it my own making) I'm happy with the engine/gearbox fitting but hope someone learns from the two basic mistakes that I made. Here is a link to the engine running (if it works)

https://www.youtube.com/watch?v=1ElS1P34PG8

Paul
Attached Images
File Type: jpg red1DSC07914.JPG (257.9 KB, 24 views)
File Type: jpg red2IMG_5716red.jpg (516.6 KB, 24 views)
File Type: jpg red3IMG_5721red.jpg (540.0 KB, 22 views)
File Type: jpg red4IMG_1483.jpg (472.9 KB, 24 views)
File Type: jpg red5IMG_1464.jpg (503.2 KB, 22 views)
File Type: jpg red6DSC01028.jpg (998.5 KB, 24 views)
File Type: jpg red7DSC01053.jpg (963.1 KB, 24 views)
File Type: jpg red8DSC01105.jpg (430.7 KB, 24 views)
File Type: jpg red9sdDSC01253.jpg (386.6 KB, 26 views)
File Type: jpg red10DSC01244.jpg (986.4 KB, 22 views)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:08 AM.

The Future Is Bright... The Future Is ZClub!

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright ZClub.net, All Rights Reserved.